swoole php7 扩展安装失败

In file included from /home/swoole-src-swoole-1.7.17-stable/swoole.c:19:0: /home/swoole-src-swoole-1.7.17-stable/php_swoole.h: In function sw_zend_hash_fi nd : /home/swoole-src-swoole-1.7.17-stable/php_swoole.h:144:12: warning: assignment f rom incompatible pointer type [enabled by default] key = _key; ^ /home/swoole-src-swoole-1.7.17-stable/php_swoole.h: In function swoole_get_obje ct : /home/swoole-src-swoole-1.7.17-stable/php_swoole.h:203:5: error: unknown type na me zend_object_handle’ zend_object_handle handle = Z_OBJ_HANDLE_P(object); ^ /home/swoole-src-swoole-1.7.17-stable/php_swoole.h: In function swoole_set_obje ct : /home/swoole-src-swoole-1.7.17-stable/php_swoole.h:210:5: error: unknown type na me zend_object_handle’ zend_object_handle handle = Z_OBJ_HANDLE_P(object); ^ make: *** [swoole.lo] Error 1

2015-06-18 11:36
0
0

韩天峰 - 关注外星人

赞同来自:

swoole 1.7.17 不支持PHP7

2015-06-18 13:51

要回复问题请先登录注册