swoole TCP服务开启SSL时,提示 Use of undefined constant SWOOLE_SSL

代码是按文档示例写的:

$server = new swoole_server("0.0.0.0", 9511, SWOOLE_PROCESS, SWOOLE_SOCK_TCP | SWOOLE_SSL );

ps:swoole版本1.8.7

2016-07-15 15:19
0
1

jzTester - it民工

赞同来自: bluse

编译时加上参数以支持SSL

2016-07-15 18:17
0

skypeng123 - php

赞同来自:

./configure --enable-sockets --enable-openssl --with-php-config=/usr/local/php/bin/php-config --enable-swoole-debug

加了这些参数还是不行,是什么情况?

2016-07-15 18:32
0

bluse

赞同来自:

同样的问题! 好多坑啊! 坑死孙子了!

2017-05-21 18:05
0

bluse

赞同来自:

嗯,确是加上 --enable-openssl 就好使了,收回我前边的话!

2017-05-21 18:46
0

阿讷

赞同来自:

之前用pecl安装的,先卸载掉,然后编译安装。

2018-03-13 09:47
0

阿讷

赞同来自:

2018-03-13 09:49
0

smx

赞同来自:

为啥openssl 扩展加不上!!~~~

2018-08-28 11:11

要回复问题请先登录注册